В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ira113311
ira113311
16.04.2021 23:54 •  Информатика

Одномерные массивы: составить программу, заполняющую массив, состоящий из n элементов, введенными с клавиатуры целыми числами. требуется вывести массив на экран компьютера и найти индекс последнего по счету в массиве отрицательного элемента.

Показать ответ
Ответ:
ашме
ашме
02.10.2020 15:02
Var n:array [1..999] of integer;
a,i,c:integer;
begin
write ('Введите кол-во элементов: ');
readln (a);
c:=0;
for i:=1 to a do
begin
write ('Введите ',i,' элемент: ');
readln (n[i]);
if n[i]<0 then c:=i;
end;
WRITELN;
write ('Введённый массив: ');
for i:=1 to a do
begin
write (n[i],' ');
end;
WRITELN;
if c>0 then writeln ('Индекс последнего введённого отрицательного элемента ',c) else writeln ('Отрицательных элементов не было введено!');
end.

Одномерные массивы: составить программу, заполняющую массив, состоящий из n элементов, введенными с
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота