В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
cat504
cat504
10.01.2023 20:13 •  Информатика

Огэ 20.2. паскаль. требовалось написать программу, определяющую количество трехзначных чисел, кратных 3. я написал: if (x> 99) and (x< 999)and (x mod = 0) then i: = i+1 снимут ли за (x< 999) ,а не (x< 1000)

Показать ответ
Ответ:
olgauschap1
olgauschap1
05.07.2020 12:24

Var

A:array[1..3]of integer;

P,k:integer;

Begin

P:=3;

While p>0 do begin

If a[p]<9 then begin

Inc(a[p]);

P:=3;

If (a[1]>0)and((a[1]*100+a[2]*10+a[3]) mod 3 = 0 then inc(k);

End

Else begin

A[p]:=0;

P:=p-1;

End;

End;

Writeln(k);

End.

Попробуй эту прогу

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота