Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
madam7952
03.09.2021 16:21 •
Информатика
Опишите двумерный массив (матрицу) g, состоящую из 5 строк и 16 столбцов. Все элементы вещественного типа.
Показать ответ
Ответ:
EvilQueen25
15.02.2021 07:41
[l,r,строка,номер]
[0, 0, "a", 1]
[1, 1, "b", 2]
[1, 2, "bb", 3]
[2, 2, "b", 4]
[0, 3, "abba", 5]
[3, 3, "a", 6]
[3, 4, "aa", 7]
[4, 4, "a", 8]
[3, 5, "aaa", 9]
[4, 5, "aa", 10]
[5, 5, "a", 11]
[3, 6, "", 12]
[4, 6, "aaa", 13]
[5, 6, "aa", 14]
[6, 6, "a", 15]
[2, 7, "bb", 16]
[7, 7, "b", 17]
[6, 8, "aba", 18]
[8, 8, "a", 19]
[7, 9, "bab", 20]
[9, 9, "b", 21]
#код программы Ruby 22
s = "abbbab"
n = 0
for r in 0..s.size-1
for l in 0..r
t = s[l..r]
if t.reverse == t
n += 1
p [l,r,t,n]
end
end
end
0,0
(0 оценок)
Ответ:
Яра3838367373
11.04.2021 10:56
Думаю нет большой разницы между процедурой и функцией, просто функция куда удобнее.
Для нахождения нода используется алгоритм Эвклида
//PascalABC.Net
function NOD(A, B: integer): integer;
begin
while A <> B do
if A > B then A := A - B else B := B - A;
NOD := A;
end;
procedure pNOD(A, B: integer; var NOD: integer);
begin
while A <> B do
if A > B then A := A - B else B := B - A;
NOD := A;
end;
begin
var a: Array of integer := (16, 32, 40, 64, 80, 128);
var n := a[low(a)];
for var i := low(a) to high(a) do
pNOD(n, a[i], n);
Writeln(n);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
LAMuK
17.03.2022 14:26
Правильных ответа три информатика СОЧ...
arifnabiev83
05.02.2023 22:08
1) Сколько трёхзначных чисел можно составить из цифр 1, 2, 3 при условии, что цифры не должны повторяться? Нарисуй граф возможных вариантов. Перечисли все числа. Запиши ответ. 2) Сколько...
zukhra1234
20.05.2020 01:20
Вычислите функции у1 =х+10,у2-х+60 при значениях х-6;1;...;63,3и постройте сравненительную диаграмму значений функций у1 и у2...
bili0909
04.03.2020 22:02
1.Представьте в виде построчной записи алгоритм решения следующей задачи: Фруктовый магазин продаёт яблоки поштучно по 10 рублей., груши по 20.,апельсины по 30 рублей. В первые два...
yeghiazaryanhap01lbi
23.09.2021 12:46
1с какой целью используется гиперссылка 2)есть ли разница между ссылкой и гиперссылкой 3)для чего используется инструмент подсказка при создании гиперссылки? 4)почему важно создание...
Hyina
28.01.2022 02:19
30 ! по блок схеме, решите обратную , определите условие ....
ппопцгуарг
19.10.2021 04:47
Доказать тождество методом анализа схем, составленных их вентилей...
rytryt
23.12.2022 01:06
Какие счётные машины были изобретены в мире до начала эпохи ЭВМ?...
daryia210407
28.06.2022 21:33
Определите значение переменной x после выполнения фрагмента алгоритма . x: =15 y: =35 x 30 ? нет конец да x =y? да x: =x-5 y: =y+5 идет в начало если так нет x: =x+10 y: =y-10...
alenakoryakovaa
06.01.2022 05:14
Несмотря на то, что photoshop – это растровый редактор, в нем некоторые элементы изначально как векторные. например, текст. чтобы можно было с текстом работать как с растровым изображением,...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
[0, 0, "a", 1]
[1, 1, "b", 2]
[1, 2, "bb", 3]
[2, 2, "b", 4]
[0, 3, "abba", 5]
[3, 3, "a", 6]
[3, 4, "aa", 7]
[4, 4, "a", 8]
[3, 5, "aaa", 9]
[4, 5, "aa", 10]
[5, 5, "a", 11]
[3, 6, "", 12]
[4, 6, "aaa", 13]
[5, 6, "aa", 14]
[6, 6, "a", 15]
[2, 7, "bb", 16]
[7, 7, "b", 17]
[6, 8, "aba", 18]
[8, 8, "a", 19]
[7, 9, "bab", 20]
[9, 9, "b", 21]
#код программы Ruby 22
s = "abbbab"
n = 0
for r in 0..s.size-1
for l in 0..r
t = s[l..r]
if t.reverse == t
n += 1
p [l,r,t,n]
end
end
end
Для нахождения нода используется алгоритм Эвклида
//PascalABC.Net
function NOD(A, B: integer): integer;
begin
while A <> B do
if A > B then A := A - B else B := B - A;
NOD := A;
end;
procedure pNOD(A, B: integer; var NOD: integer);
begin
while A <> B do
if A > B then A := A - B else B := B - A;
NOD := A;
end;
begin
var a: Array of integer := (16, 32, 40, 64, 80, 128);
var n := a[low(a)];
for var i := low(a) to high(a) do
pNOD(n, a[i], n);
Writeln(n);
end.