В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
PatrickKKK
PatrickKKK
25.03.2022 12:17 •  Информатика

Опишите назначение заголовка программы, раздела описания переменных и раздела констант. Приведите примеры записи заголовка, раздела описания переменных и раздела констант на Паскале. ( ). Опишите типы данных для численных переменных в Паскале. ( ).
Как записываются операторы ввода/вывода на Паскале? Приведите примеры записи каждого оператора. ( ).
Напишите программу на Паскале для нахождения значения выражения С = А*(2В-А). Значения переменных А и В задать самостоятельно с клавиатуры. На проверку нужно прислать скриншот окна программы на Паскале с результатом работы. ( ).
Опишите принцип работы линейного алгоритма. Из каких команд составляется линейный вычислительный алгоритм? ( ).
В каком случае значение переменной считается неопределенным? Приведите пример. ( ).
Напишите на алгоритмическом языке алгоритм вычисления y по формуле:
y = (5 + x2 - x4)4
где х — заданное целое число. Учтите следующие ограничения: 1) в арифметических выражениях можно использовать только операции сложения, вычитания и умножения; 2) каждое выражение может содержать только одну арифметическую операцию. Выполните трассировку алгоритма при х = 2. ( ).
Объясните понятие алгоритмической структуры «ветвление» и ее значение. Приведите пример данной структуры на Паскале. ( ).
Напишите программу на Паскале для решения следующей задачи. Даны два числа A и B, которые не равны друг другу. Большее из этих чисел нужно заменить половиной разности этих двух чисел, а меньшее — их удвоенным произведением. Значения A и B задать самостоятельно с клавиатуры. На проверку нужно прислать скриншот окна программы на Паскале с результатом работы. ( ).

Показать ответ
Ответ:
KIRILLX228
KIRILLX228
18.10.2020 12:14
Процессор - Intel Core i5-3450 Ivy Bridge (3100MHz, LGA1155, L3 6144Kb) - 6000
Материнская плата - ASUS P8Z77-V LX - 3600
Оперативная память - Kingston KVR16N11/8 - 3000
Видеокарта - GIGABYTE GeForce GTX 650 1110Mhz PCI-E 3.0 1024Mb 5000Mhz 128 bit 2xDVI HDMI HDCP - 3600
HDD - Seagate ST1000DM003 - 2100
Блок питания - Thermaltake TR2 RX 750W - 3500
Корпус - Zalman Z12 Plus Black - 2500
Сканер - Epson Perfection V37 - 4500
Монитор - Packard Bell Viseo 223DXbd - 3900
Дешевая клавиатура - 400
Дешевая мышь - 400

Итого 33500 руб. - 1500 на мороженное.
0,0(0 оценок)
Ответ:
2005NeZnayka2005
2005NeZnayka2005
15.02.2020 02:54

import datetime

m = 12

d = 12

year = 2020

y2021 = datetime.date(year=2021, month=m, day=d)

for i in range(20):

   year += 1

   y = datetime.date(year=year, month=m, day=d)

   da = datetime.datetime.isoweekday(y)

   print(da)

   if  7 == da  :

       print("Sunday")

       print(y)

   elif 6== da :

       print("Saturday")

       print(y)

   elif 5== da :

       print("friaday")

       print(y)

   elif 4== da:

       print("Tuesday")

       print(y)

   elif 3== da:

       print("Wensday")

       print(y)

   elif 2 == da:

       print("Вторник")

       print(y)

   elif 1 == da:

       print("Monday")

       print(y)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота