В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Maria20511
Maria20511
29.03.2020 00:27 •  Информатика

Определите и опишите команды циклического алгоритма в среде программирования Scratch.
повторять пока не всегда если , то повторить 10 если , то
иначе

Показать ответ
Ответ:
Анжеkf23
Анжеkf23
08.01.2020 05:46

Пример работы на рисунке 1.

Код:

#include <iostream>

#include <clocale>

#include <string>

using namespace std;


int main() {

setlocale(LC_ALL, "Russian");


//Входные данные

int K = 43;


if(K < 1 || K > 365) {

 cout << "Неверные входные данные";

 return 1;

}

// Дни

string Days[] = { "Понедельник", "Вторник", "Среда", "Четверг", "Пятница", "Суббота", "Воскресение" };

int N = K % 7;

cout << "День года №" << K << " называется " << Days[N] << endl;

system("pause");

return 0;

}


Вс++ дни недели пронумерованы следующим образом: 1- понедельник, 2 -вторник, ..6-суббота, 7 - воскре
0,0(0 оценок)
Ответ:
Пенёк155
Пенёк155
16.09.2022 10:19

#include <iostream>


#include <cstdlib>


#include <ctime>


using namespace std;


int main()


{


int m[15] = {};


double t = 0;


srand(time(NULL));  // генерация нового числа всегда разная, т.к берётся разное время

for (int i = 0; i < 15; i++)


{


 m[i] = rand();


 cout << "[" << i+1 << "] " << m[i] << endl;


 t = t + m[i];


}


cout << endl << t << "/15 = " << t / 15 << endl;


}

Проверка:

прикреплённое фото

11737 + 5520 + 24807 + 25121 + 13476 + 31412 + 28456 + 32654 + 8 + 14540 + 12889 + 8915 + 8179 + 19225 + 30596 = 267535


С++ составить массив из 15 рандомных элементов и вывести среднее арифметияеское этих чисел в с++
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота