Определите, к какому виду прикладных программ относятся перечисленные ниже программные продукты. 1) Текстовые редакторы 2) Графическине редакторы 3) Электронные таблицы 4) Bеб-редакторы 5) Веб-браузеры Орera. MS Excel, MS PromPage, Adobe Photoshop. Corel WordPerfect
begin
Otr := sqrt(sqr(Ax - Bx) + sqr(Ay - By))
end;
function Perim(Ax, Ay, Bx, By, Cx, Cy: real): real;
begin
Perim := Otr(Ax, Ay, Bx, By) + Otr(Bx, By, Cx, Cy) + Otr(aX, aY, Cx, Cy);
end;
function Area(Ax, Ay, Bx, By, Cx, Cy: real): real;
var
pp: real;
begin
pp := Perim(Ax, Ay, Bx, By, Cx, Cy) / 2;
Area := sqrt(pp * (pp - Otr(Ax, Ay, Bx, By)) * (pp - Otr(Bx, By, Cx, Cy)) *
(pp - Otr(Ax, Ay, Cx, Cy)))
end;
procedure Dist(Px, Py, Ax, Ay, Bx, By: real; var D: real);
begin
D := 2 * Area(Px, Py, Ax, Ay, Bx, By) / Otr(Ax, Ay, Bx, By)
end;
var
Px, Py, Ax, Ay, Bx, By, Cx, Cy: real;
d: real;
begin
writeln('Вводите координаты точкек парами чисел: ');
write('P-> ');
readln(Px, Py);
write('A-> ');
readln(Ax, Ay);
write('B-> ');
readln(Bx, By);
write('C-> ');
readln(Cx, Cy);
writeln;
Dist(Px, Py, Ax, Ay, Bx, By, d);
writeln('Расстояние от Р до АВ равно ', d);
Dist(Px, Py, Cx, Cy, Bx, By, d);
writeln('Расстояние от Р до ВC равно ', d);
Dist(Px, Py, Ax, Ay, Cx, Cy, d);
writeln('Расстояние от Р до АC равно ', d)
end.
Тестовое решение:
Вводите координаты точкек парами чисел:
P-> -3 6
A-> 5 8
B-> 9 -4
C-> 8 -2.5
Расстояние от Р до АВ равно 8.22192191643778
Расстояние от Р до ВC равно 4.43760156980184
Расстояние от Р до АC равно 8.24163383692135
Вопрос 1. ЭТ – это
1)Прикладная программа, предназначенная для обработки структурированных в виде таблицы данных
Вопрос 2. ЭТ предназначена для
1)обработки числовых данных, представленных в виде таблиц
Вопрос 3. ЭТ представляет собой
2)совокупность пронумерованных строк и поименованных буквами латинского языка столбцов
Вопрос 4. Строки ЭТ
4)нумеруются
Вопрос 5. Столбцы ЭТ
3)обозначаются буквами латинского языка
Вопрос 6. Для пользователя ячейка ЭТ идентифицируется
3)путем последовательного указания имени столбца и номера строки, на пересечении которых располагается ячейка
Вопрос 7. Вычислительные формулы в ячейках ЭТ записываются
2)специальным образом с использованием встроенных функций и по правилам, принятым для записи выражений в языках программирования
Вопрос 8. Выражение 3 (А1+В1) : 5 (2В1-3А2), записанное в соответствии с правилами,
принятыми в математике, в ЭТ, имеет вид
1)3* (А1+В1)/(5*(2*В1-3*А2))
Вопрос 9. Среди приведенных отыщите формулу для ЭТ
4)=А3*В8+12
Вопрос 10. Запись формулы в ЭТ не может включать в себя
4)текст
Вопрос 11. При перемещении или копировании в ЭТ абсолютные ссылки
1)не изменяются
Вопрос 12. При перемещении или копировании в ЭТ относительные ссылки
1)преобразуются в зависимости от нового положения формулы
Вопрос 13. Диапазон - это
1)совокупность клеток, образующих в таблице область прямоугольной формы
Вопрос 14. Активная ячейка - это ячейка
4)в которой выполяется ввод данных
Вопрос 15. Какая Формула будет получена при копировании в E4 формулы из Е2?
(если предположить, что в Е2 записано =$А$2*С2)
3)=$A$2*C4
Вопрос 16. Какая Формула будет получена при копировании в E4 формулы из Е2?
(если предположить, что в Е2 записано =$A$2*5)
4)=$A$2*5
Вопрос 17. Какая Формула будет получена при копировании в E4 формулы из Е2?
(если предположить, что в Е2 записано =A2*C2)
4)=A4*C4
Вопрос 18. Чему будет равно значение в ячейке С1, если в нее ввести формулу =А1+В1?
(если предположить, что в A1=10, B1=A1/2)
1)15
Вопрос 19. Чему будет равно значение в ячейке С1, если в нее ввести формулу
=СУММ(А1:В1)*2?
(если предположить, что в A1=5, B1=A1*2)
4)30
Вопрос 20. Сортировкой называют
4)процесс линейного упорядочения некоторого множества