В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
lozhe4ka
lozhe4ka
07.08.2021 03:41 •  Информатика

Определите, количество чисел k, для которых следующая программа выведет такой же результат, что и для k = 17?
var k, i : longint;
function f(n: longint): longint;
begin
f:= n*n*n + 5*n*n;
end;
begin
readln(k);
i := 1;
while f(i) < k do
i := i + 1;
if f(i)-k <= k-2*f(i-1) then
writeln(i)
else writeln(i-1);
end.

Показать ответ
Ответ:
kira260606
kira260606
07.01.2021 06:12

17

Объяснение:

k от 3 до 19 будет иметь такой же результат

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота