В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Huuur
Huuur
06.03.2023 02:44 •  Информатика

Определите, количество каких элементов подсчитывается с следующего фрагмента программы. k:=0;
for i:=1 to n do
if a[i]>50 then k:=k+1;
write ('k=',k)

Показать ответ
Ответ:
маг42
маг42
07.04.2022 02:27

1)

#include <iostream>

using namespace std;

int main ()

{

   int k = 0;

   int n, m, a[100][100];

   cin >> n >> m;

   for (int i = 0; i < n; i++){

       for (int j = 0; j < m; j++){

           cin >> a[i][j];      

       }

   }

   for (int i = 0; i < n; i++){

       for (int j = 0; j < m; j++){

        if(a[i][j]==a[j][i]){

        k++;

        }

       }

   }

   cout<<"Количество элементов a[i][j] = a[j][i], " << k << endl;

}

2)

#include <iostream>

using namespace std;

int main ()

{

   int a[100], n, m,s = 0;

   cout << "Введите количество элементов массива" << endl;

   cin >> n;

   cout << "Введите заданное число" << endl;

   cin >> m;

   for(int i = 0; i<n;i++){

       cout << "Введите " << i+1 << " элемент массива" << endl;

       cin >> a[i];

   }

   for(int i = 0; i<n;i++){

       if(a[i] > m){

           s+=a[i];

       }

   }

   cout << "Сумма элементов, больших заданного числа "<< s << endl;

   

}

0,0(0 оценок)
Ответ:
CoolGirl78
CoolGirl78
15.06.2022 22:23
// PascalABC.NET 3.2, сборка 1439 от 09.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество строк в матрице:');
  var m:=ReadInteger('Количество столбцов в матрице:');
  Writeln('*** Исходная матрица [',n,',',m,'] ***');
  var a:=MatrRandom(n,m,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  var s:=a.Row(0).Sum+a.Row(n-1).Sum;
  s+=a.Col(0).Skip(1).Take(n-2).Sum+a.Col(m-1).Skip(1).Take(n-2).Sum;
  Writeln('Сумма по периметру ',s)
end.

Пример
Количество строк в матрице: 4
Количество столбцов в матрице: 5
*** Исходная матрица [4,5] ***
  87 -67  11  59  46
 -13  86 -74  20 -98
 -74  24   6  51  74
  26 -93  36  40  66

Сумма по периметру 100
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота