Организуйте в консольном приложении ввод массива декартовых координат n точек в трёхмерном пространстве. вычислите массив полярных координат этих точек и организуйте вывод этого массива. обеспечьте контроль вводимых значений.организуйте в windows ввод массива декартовых координат n точек в трёхмерном пространстве. вычислите массив полярных координат этих точек и организуйте вывод этого массива. обеспечьте контроль вводимых значений.
Объяснение:
const
n = 10;
ar:array[1..n] of integer = (-2, -1, 2, 3, 4, 5, -5, -6, 2, 5);
var
i:integer;
is_first_pol:boolean;
raz_pol:integer;
begin
raz_pol:=0;
is_first_pol:=true; // флаг того, что найденное положительное число - первое
for i:=1 to n do begin
if (ar[i] > 0) then
if (is_first_pol) then begin
// если найденное полодительное число - первое, то
raz_pol:=ar[i]; // в нашу разницу заносим это число
is_first_pol:=false; // меняем флаг
end
else raz_pol:=raz_pol - ar[i]; // иначе вычисляем разницу
end;
writeln(raz_pol);
end.
перо Сместиться в точку (1,7) Сместиться в точку (1,5) Поднять перо Сместиться на вектор (0,-2) Опустить перо Сместиться на вектор (2,0) Сместиться в точку (3,5) Сместиться на вектор (-2,0) Поднять перо Сместиться в точку (4,5) Опустить перо Сместиться на вектор (2,0) Поднять перо Сместиться в точку (5,6) Опустить перо Сместиться в точку (5,4) Поднять перо Сместиться в точку (7,3) Опустить перо Сместиться на вектор (2,0) Сместиться на вектор (0,4) Сместиться в точку (7,7) Сместиться в точку (7,5) Сместиться в точку (9,5) Поднять перо В ответе укажите только число, без пробелов и каких-либо знаков препинания, например 100 ответ:
Объяснение: