В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

ОТ ТОМУ КТО РЕШИТ!!

Написать программу на Паскале для решения задачи.

Вычислить произведение модулей элементов одномерного массива из 20 чисел, расположенных после первого отрицательного элемента. Входные данные задать самостоятельно.

Показать ответ
Ответ:
AlinkaMakovka
AlinkaMakovka
13.11.2020 19:50
Const nx=20;
var i,j,n,s:integer; A,B:array[1..nx,1..nx] of real;min,t:real;
z:array[1..nx] of real;
begin
min:=100;
write('Введите размер матрицы n');Readln(n);
for i:=1 to n do begin
for j:=1 to n do begin
A[i,j]:= sin(j)*(1-sin(i));
write(A[i,j]:9:4);
if min > A[i,j] then begin min:= A[i,j];s:=i;end;
end;writeln;end;writeln;
i:=s;
for j:=1 to n do begin
z[j]:=A[i,j];write(z[j]:9:4);end;
for i:=1 to n do begin
for j:=2 to n do begin
if z[j-1]> z[j] then begin
t:=z[j-1];z[j-1]:=z[j];z[j]:=t
end;end;end;
writeln;
i:=s;
for j:=1 to n do begin
A[i,j]:=z[j];write(z[j]:9:4);end;
writeln;writeln;
for i:=1 to n do begin
for j:=1 to n do begin
B[i,j]:= A[i,j];write(B[i,j]:9:4);end;
writeln;end;
writeln;write('min = ',min:9:4, '   I = ', s);
end.
0,0(0 оценок)
Ответ:
Deliya2000
Deliya2000
19.11.2021 14:33
Var  s          : string;  finish,k,i : longint;begin  assign(input,'input.txt'); reset(input);  assign(output,'output.txt'); rewrite(output);  finish:=0;  while(finish=0) do { если finish будет <> 0 то программа    перестанет читать текст}    begin      writeln('читать? если да, то 0 если нет, то 1');      readln(finish);      k:=0;      if finish=0        then begin               readln(s);               for i:=1 to length(s) do                 if s[i]=' '                   then inc(k);             end        else exit;      inc(k);      writeln(k);    end;end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота