В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
nvede
nvede
21.04.2020 02:55 •  Информатика

ответь на вопросы по информатике. 1) Напишите программу, котораязапрашивает ввести несколько
слов с клавиатуры, а затем определяет длинусамого короткого
слова в строке.
2) Строковый метод isdigit() проверяет, состоит ли строка
только из цифр. Напишите программу, которая запрашивает с
ввода два целых числа и выводит их сумму. В случае некорректно-
го ввода программа не должна завершатьсошибкой, а должна
продолжать запрашивать числа. Обработчик исключений try-
except использовать нельзя.​

Показать ответ
Ответ:
saba22
saba22
27.03.2021 16:53

1) Ввод осуществляется в строку через пробел. В конце enter.

s = [i for i in input().split()]

min = len(s[0])

for i in s:

   if len(i) < min:

       min = len(i)

print(min)  

2) Осуществляешь ввод числа, если это не число, а символ, то программа будет снова запрашивать ввод до тех пор, пока в переменной не появится число.

a = input()

while not (a.isdigit()):

   a = input()  

b = input()

while not (b.isdigit()):

   b = input()  

print(int(a)+int(b))    

   

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота