В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ak067
ak067
22.01.2020 18:26 •  Информатика

Палиндром - слово, читающееся в обе стороны одинаково. Напишите программу, которая превращает в палиндром любое слово, вычеркивая из него минимальное количество букв. Словом будем считать последовтельность строчных букв латинского алфавита. Ввод-вывод
Вы вводите с клавиатуры слово - последовательность малых латинских букв без пробелов (не более 255 символов). Вы выводите на экран одно число - минимальное количество символов, которые нужно удалить, чтоб слово стало палиндромом.

Примеры:
1. Ввод > qwerrewtq
Вывод < 1
2. Ввод > qwert
Вывод < 4

Показать ответ
Ответ:
ЯLOVEспорт
ЯLOVEспорт
02.01.2022 06:20

Python:

results = []

 

def make_palindrome(string, count=0):

   if string == string[::-1]:

       results.append(count)

   else:

       for i in range(len(string)):

           make_palindrome(string[:i] + string[i + 1:], count + 1)

make_palindrome(input())

print(min(results))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота