В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Zaher11
Zaher11
24.06.2021 14:49 •  Информатика

Pascal ! 1. составьте программу, вычисляющую, сколько букв надо исправить в слове х, чтобы получилось слово y (слова x и y одинаковой длины). 2. составьте программу, определения номера первой буквы "а" в слове х. 3. составьте программу, позволяющую выяснить, первая или последняя буква слова встречается в слове х чаще.

Показать ответ
Ответ:
Марси667
Марси667
25.06.2020 21:48
Задача 1.
var
  i,c: integer;
  x,y: string;

begin
  readln(x);
  readln(y);
  for i:=1 to length(x) do
    if x[i]<>y[i] then inc(c);
  writeln('Букв надо исправить = ',c)
end.

Задача 2.

var
  i: integer;
  x: string;

begin
  readln(x);  i:= 1;
  while x[i]<>'a' do inc(i);  // Здесь, в зависимости с какой буквой сравнивать, либо с русской, либо с англ.
  writeln(i)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота