В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
sona272
sona272
15.04.2020 09:24 •  Информатика

Pascal abc составить программу для нахождения s дано натуральное число n. найти сумму s=1- 1/5 + 1/9 - 1/+ (n-слагаемых) !

Показать ответ
Ответ:
biolev
biolev
07.10.2020 11:12
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  Writeln(Range(0,n-1).Select(i->1/(i.IsEven?4*i+1:-(4*i+1))).Sum)
end.

Пример
n= 13
0.876761945581588

для Pascal ABC (проверить негде, проект закрыт в 2004 году)

var
  i,n,z:integer;
  x,s:real;

begin
  Write('n='); Read(n);
  s:=0; z:=1;
  for i:=0 to n-1 do begin
    x:=1/(4*i+1);
    s:=s+x*z;
    z:=-z
    end;
  Writeln(s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота