Pascal abc. составить программу , определяющую , является ли шестизначный номер билета счастливым (у которого сумма первых трех цифр равна сумме последних трех цифр) p.s. нужно использовать div и mod..
Var a: integer; begin readln(a); if(a div 100000 + ((a div 1000) mod 10) + (((a div 1000) div 10) mod 10) ) = (((a mod 1000) div 100) + ((a mod 1000) mod 10) + (((a mod 1000) div 10) mod 10)) then writeln('Да') else writeln('Нет'); end.
begin
readln(a);
if(a div 100000 + ((a div 1000) mod 10) + (((a div 1000) div 10) mod 10) ) = (((a mod 1000) div 100) + ((a mod 1000) mod 10) + (((a mod 1000) div 10) mod 10)) then writeln('Да')
else writeln('Нет');
end.