Pascal.abc составьте программу! на марс отправляется туристический космолет, который может иметь на борту не более 750 пассажиров. туристы прибывают группами, количество человек в которых различно. составьте программу, регулирующую наполняемость космолета, а также вычисляющую необходимое количество гидов (по одному на группу).
uses crt;
var a,g,i,s,s2:integer;
begin
I:=1;
s:=0;
while i<>0 do begin
read(a);
s:=s+a;
If s>=750 then begin
i:=0;
end;
If s<=750 then begin
g:=g+1;
end;
end;
If s>750 then begin
s2:=s-750;
writeln( ' Не осталось мест для ',s2);
end;
If s>750 then begin
s2:=s-a;
writeln('Всего попало на космолёт :',s2);
end;
749
writeln('Понадобилось гидов :',g);
end.