В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
dscirina
dscirina
18.05.2020 05:22 •  Информатика

Pascal / c++ на вход программе два целых числа: n и m, каждое в отдельной строке 0 < n < = 12 0 < = m < 60, указывающие момент времени "n часов m минут". определите наименьшее число полных минут, которое должно пройти до того момента, когда часовая и минутная стрелки ни циферблате совпадут, не обязательно на каком-то делении. вещественную арифметику не использовать. необходимо решить без использования условных операторов (в том числе без тернарного оператора ? : в с++) и\или циклов. кроме того нельзя использовать операции сравнения и логический (булевский) тип данных. примеры входные данные 2 50 выходные данные 26 входные данные 3 0 выходные данные 16

Показать ответ
Ответ:
окей129
окей129
08.10.2020 08:31
// часовая стрелка: 1 час - 30 град, 2 мин - 1 град
// минутная стрелка: 1 мин - 6 град
// m*6+k*6-360 = (n*60+m+k)/2
var n,m,k:integer;
begin
 readln(n);
 readln(m);
 k:=(60*n-11*m+720) mod 360 div 11;
 writeln(k);
end.

Пример:
2
50
26
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота