Pascal. для решения используйте используйте цикл с предусловием. постройте блок - схему и напишите программу для нахождения суммы десяти первых элементов ряда.
1.В текстовому процесорі Word передбачена можливість змінювати варіанти оформлення маркованих та нумерованих списків.
2.Вказані кнопки групи Абзац мають відповідно таке призначення: маркований список, нумерований список, багаторівневий список.
3.Розмістивши курсор у потрібному місці документа, слід увести спеціальні умовні символи, які визначають вид бажаного списку, і натиснути клавішу Пропуск
Одразу ж умовні символи перетворяться на відповідний маркер або номер.
Далі можна розпочинати введення першого елемента списку.
4.Відмінити нумерацію (маркування) після закінчення введення елементів списку можна повторним вибором кнопки списку або натиснення клавіші Backspace.
5.Двічі клацніть числа у списку. Текст не буде виділено.
Клацніть правою кнопкою миші номер, який потрібно змінити.
Натисніть кнопку Установити значення нумерування.
У полі Установити значення: за до стрілок змініть значення на потрібне число.
Відповідь:
1.В текстовому процесорі Word передбачена можливість змінювати варіанти оформлення маркованих та нумерованих списків.
2.Вказані кнопки групи Абзац мають відповідно таке призначення: маркований список, нумерований список, багаторівневий список.
3.Розмістивши курсор у потрібному місці документа, слід увести спеціальні умовні символи, які визначають вид бажаного списку, і натиснути клавішу Пропуск
Одразу ж умовні символи перетворяться на відповідний маркер або номер.
Далі можна розпочинати введення першого елемента списку.
4.Відмінити нумерацію (маркування) після закінчення введення елементів списку можна повторним вибором кнопки списку або натиснення клавіші Backspace.
5.Двічі клацніть числа у списку. Текст не буде виділено.
Клацніть правою кнопкою миші номер, який потрібно змінити.
Натисніть кнопку Установити значення нумерування.
У полі Установити значення: за до стрілок змініть значення на потрібне число.
Пояснення:
Відповідь:
#include <iostream>
using namespace std;
const int size = 10;
void cinarr(int *arr,const int size){
int counter = 1;
for(int i = 0; i < size; i++){
cout << "Введите " << counter << " елемент массива: ";
cin >> arr[i];
counter++;
}
}
void printarr(int *arr, const int size){
for(int i = 0; i < size; i++){
cout << arr[i] << " ";
}
}
int expression(int *arr,const int size,int number){
int counternumber = 0;
for(int i = 0; i < size; i++){
if(number == arr[i]){
counternumber++;
}
}
return counternumber;
}
int main(){
setlocale(LC_ALL , "Rus");
int number;
cout << "Введите число которое будем искать: ";
cin >> number;
int *arr = new int [size];
cinarr(arr,size);
printarr(arr,size);
cout << "\nТаких чисел в массиве: " << expression(arr,size,number) << endl;;
delete [] arr;
return 0;
}
Пояснення: