В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Анон5сен
Анон5сен
14.07.2022 02:01 •  Информатика

Pascal написать программу с использованием цикла с параметром. дано целое число n (> 0). найдите произведение 1/6*4/11**n^2/(n^2+2n+3) (вещественное число)

Показать ответ
Ответ:
amura20
amura20
13.08.2020 23:20
\displaystyle \prod_{i=1}^n{\frac{i^2}{n^2+2n+3}}=\prod_{i=1}^n{\frac{i^2}{(i+1)^2+2}}, \quad n \in \mathbb N

// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var p:=1.0;
  for var i:=1 to ReadInteger('n=') do
    p*=sqr(i)/(sqr(i+1)+2);
  Writeln(p)
end.

Тестовое решение
n= 10
0.00308222811150801
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота