В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Атмир089997
Атмир089997
08.12.2020 07:33 •  Информатика

PASCAL написать программу Заданы три последовательности чисел разной длины. Сформировать новую последовательность, в которую должны войти только те числа, которые есть во второй последовательности, но отсутствуют в первой. Использовать подпрограмму поиска элемента.

Показать ответ
Ответ:
qwertyuiop330
qwertyuiop330
13.07.2021 20:22
#include <stdio.h>#include <locale.h>#include <conio.h>int main(){ int boys = 0, count_boys = 0; int girls = 0, count_girls = 0; int tmp = 1; setlocale(LC_ALL, "rus"); printf("Введите рост ученика\nРост мальчиков задается отрицательными значениями\nРост девочек положительными\n"); printf("Введите 0 если ввели рост всех учеников\n"); // вводим рост учеников while (tmp != 0) { scanf_s("%d", &tmp); if (tmp > 0) { girls += tmp; count_girls++; } else if (tmp < 0) { boys += tmp; count_boys++; } } // вычисляем средний рост учеников if (count_boys > 0 && count_girls > 0) {  boys = -boys / count_boys; girls = girls / count_girls; } else { printf("Рост мальчиков либо девочек не был задан\n"); _getch(); return 0; }
if ((boys - girls) > 10) printf("Средний рост мальчиков больше среднего роста девочек на 10 см\n"); else printf("Средний рост мальчиков не превышает среднего роста девочек на 10 см\n"); _getch(); return 0;}
// попытка №2

Решить на с++ известен рост каждого ученика класса. рост мальчиков условно задан отрицательными числ
0,0(0 оценок)
Ответ:
fhtyf
fhtyf
06.10.2022 05:29
Свойства алгоритма - Дискретность (прерывность, раздельность) алгоритм должен быть разделен на шаги.
Определенность – каждое правило алгоритма должно быть четким, однозначным и не оставлять места для произвола.
Результативность (конечность) – алгоритм должен приводить к решению задачи за конечное число шагов.
Массовость – алгоритм решения задачи разрабатывается в общем виде, то есть, он должен быть применим для некоторого класса задач, различающихся только исходными данными
2.алгоритм - четкая последовательность действий, приводящая к результату за конечное число шагов.
3.Типы алгоритмов - линейный, ветвление, циклический.
4. Язык высокого уровня, языки низкого уровня.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота