В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
vipborisov200
vipborisov200
10.08.2020 16:06 •  Информатика

Pascal напишите программу, которая в последовательности натуральных чисел находит количество отрицательных чисел, кратных 10. программа получает на вход натуральные числа, количество введенных числе неизвестно, последовательность чисел заканчивается числом -100 (минус 100). решить циклом while.

Показать ответ
Ответ:
Lisa030105
Lisa030105
19.07.2020 22:16
Var
  n,k:integer;
  loop:boolean;
begin
  Writeln('Введите целые числа, окончание ввода по числу -100');
  k:=0;
  loop:=true;
  while loop do
  begin
    Read(n);
    loop:=(n<>-100);
    if loop then
      if (n<0) and ((n mod 10)=0) then Inc(k)
  end;
  Writeln('Количество отрицательных чисел, кратных 10, равно ',k)
end.

Тестовое решение:
Введите целые числа, окончание ввода по числу -100
40 52 -23 16 1000 -240 35 6 0 -20 7 -100
Количество отрицательных чисел, кратных 10, равно 2
0,0(0 оценок)
Ответ:
Дарья4311
Дарья4311
19.07.2020 22:16
var
  x, s : integer;
  t: boolean;
begin
  s := 0;
  while  t=false do
    begin
      writeln(i,' число:');
      readln(x);
      if x = -100 then t:=true;
      if (x < 0) and (x mod 10 = 0)) then s:=s+1;
    end;
    writeln('ответ ',s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота