(Pascal) Определить класс Treug (треугольник), в котором реализовать метод инициализации, а также методы вычисления периметра и площади треугольника. Написать программу, демонстрирующую работу с созданным классом
is_number_divided_by() - для проверки делимости числа на kget_production_for() - реализация алгоритма вычисления заданного произведения с использованием цикла for.get_production_while() - реализация алгоритма вычисления заданного произведения с использованием цикла while.
========================
Ваши оценки и отзывы лучше оценить качество решения.
Если решение удовлетворило, то не забудь отметить его как "Лучшее".
========================
Код:
#include <iostream>
bool is_number_divided_by(int number, int fr) {
return number % fr == 0;
}
int get_production_for(int m, int n, int k) {
int production = 1;
for (int number = m; number <= n; ++number) {
if(is_number_divided_by(number, k)) {
production *= number;
}
}
return production;
}
int get_production_while(int m, int n, int k) {
int production = 1;
while (m <= n) {
if(is_number_divided_by(m, k)) {
production *= m;
}
++m;
}
return production;
}
int main() {
const int m = 3, n = 7, k = 2;
std::cout << "Getting production for m=" << m << " n=" << n << " and k=" << k << "..." << std::endl;
std::cout << "FOR way result is " << get_production_for(m, n, k) << std:: endl;
std::cout << "WHILE way result is " << get_production_while(m, n, k) << std:: endl;
Приложение принимает на ввод информацию о Именах и Фамилиях программистов, а также используемом языке и позволяет найти среди записей информацию о программистах C++.
Иллюстрации кода и тестовых ввода-вывода прикреплены во вложениях.
Ваши оценки и отзывы позволяют лучше оценить решение.
Иллюстрации кода и пример вывода прикреплен ниже.
Сам код доступен в виде текста в конце ответа.
В коде определены функции:
is_number_divided_by() - для проверки делимости числа на kget_production_for() - реализация алгоритма вычисления заданного произведения с использованием цикла for.get_production_while() - реализация алгоритма вычисления заданного произведения с использованием цикла while.========================
Ваши оценки и отзывы лучше оценить качество решения.
Если решение удовлетворило, то не забудь отметить его как "Лучшее".
========================
Код:
#include <iostream>
bool is_number_divided_by(int number, int fr) {
return number % fr == 0;
}
int get_production_for(int m, int n, int k) {
int production = 1;
for (int number = m; number <= n; ++number) {
if(is_number_divided_by(number, k)) {
production *= number;
}
}
return production;
}
int get_production_while(int m, int n, int k) {
int production = 1;
while (m <= n) {
if(is_number_divided_by(m, k)) {
production *= m;
}
++m;
}
return production;
}
int main() {
const int m = 3, n = 7, k = 2;
std::cout << "Getting production for m=" << m << " n=" << n << " and k=" << k << "..." << std::endl;
std::cout << "FOR way result is " << get_production_for(m, n, k) << std:: endl;
std::cout << "WHILE way result is " << get_production_while(m, n, k) << std:: endl;
return 0;
}
Приложение принимает на ввод информацию о Именах и Фамилиях программистов, а также используемом языке и позволяет найти среди записей информацию о программистах C++.
Иллюстрации кода и тестовых ввода-вывода прикреплены во вложениях.
Ваши оценки и отзывы позволяют лучше оценить решение.
Если ответ удовлетворил, отметь его как "Лучший".
Успехов в учёбе!
Код:
#include <iostream>
#include <string>
#include <utility>
#include <vector>
#include <exception>
struct Coder {
std::string name;
std::string lastname;
std::string language;
Coder(std::string name, std::string lastname, std::string language) :
name(std::move(name)),
lastname(std::move(lastname)),
language(std::move(language))
{ }
explicit operator std::string() const
{
return name + " " + lastname + " " + language;
}
};
struct DataBase {
private:
std::vector<Coder> _base;
public:
bool add_coder(Coder coder) {
_base.push_back(std::move(coder));
return true;
}
std::vector<Coder> search_by_language(const std::string& language_name) {
std::vector<Coder> search_results;
for(auto & coder : _base) {
if (coder.language == language_name) {
search_results.push_back(std::move(coder));
}
}
return search_results;
}
};
int main() {
DataBase base;
std::cout << "Please enter information about programmers like this \"Bjarne Stroustrup C++\" bellow" << std::endl;
std::cout << "You can type .find command for finding all added programmers who have developed with C++" << std::endl;
std::string input, name, lastname, language;
while(true) {
std::cout << "> ";
std::cin >> input;
if(input == ".find") break;
name = input;
std::cin >> lastname >> language;
base.add_coder(Coder(input, lastname, language));
}
std::vector<Coder> search_results = base.search_by_language("C++");
for(auto & search_result : search_results){
std::cout << (std::string)search_result << std::endl;
}
return 0;
}