В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
garev064danil
garev064danil
18.02.2023 19:33 •  Информатика

Pascal, составить программу с задачей! Компьютер запрашивает радиус круга и сторону квадрата. Надо определить, равные ли у них площади (ответ должен иметь вид: «Площади равные»). Если площади не равные, то выводится площадь меньшей фигуры.

Показать ответ
Ответ:
aiis17
aiis17
15.01.2021 22:25

//s1 - площадь круга, s2 - площадь квадрата

//а - cторона квадрата, r - радиус круга

const pi = 3.14;

var s1,s2,a,r:real;

begin

 write('введите а: ');

 read(a);

 write('введите r: ');

 read(r);

 s1:=pi*sqr(r);

 s2:=sqr(a);

 if s1 = s2 then writeln('площади равные')

 else

   if s1 > s2 then writeln('площадь квадрата: ',s2)

   else

     if s2 > s1 then writeln('площадь круга: ',s1);

end.

0,0(0 оценок)
Ответ:
milkdkdlol
milkdkdlol
15.01.2021 22:25

var a,r:real;

begin

 readln(r);

 readln(a);

 if (a*a)=(r*r*pi) then

   writeln('Площади равны')

 else

   if (a*a)>(r*r*pi) then

     writeln('Площадь круга меньше, она равна: ', r*r*pi)

   else

     writeln('Площадь квадрата меньше, она равна: ', a*a)

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота