В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ооардпт
ооардпт
08.08.2021 18:11 •  Информатика

Pascal.составьте программу для нахождения суммы отрицательных четных элементов двумерного массива

Показать ответ
Ответ:
myka1
myka1
02.10.2020 02:01
Program aliona;
const n =10;
var a:array[1..n,1..n] of integer;
i,j,s:integer;
begin
randomize;
for i:=1 to n do
for j:=1 to n do 
begin
a[i,j]:=random(30); 
write ( 'а(', i, ',', j, ')=', a[i,j]);
end ;
s:=0;
for i:=1 to n do begin
for j:=1 to n do begin
if a[i] (mod 2 =0) and (a[i]<0) then s:=s+a[i];
writeln('s=',s);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота