В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
dilnoza2006
dilnoza2006
04.07.2020 02:03 •  Информатика

PascalABC. Написать программу, в которой выполняются следующие действия:
1. с клавиатуры вводится имя 1-го человека;
2. с клавиатуры вводится вес 1-го человека;
3. с клавиатуры вводится имя 2-го человека;
4. с клавиатуры вводится вес 2-го человека;
5. программа выводит имя более тяжелого человека (при равенстве весов
выводится имя 2-го человека);
6. в том случае, когда вес какого-либо человека или обоих не находится в
пределах от 3 до 150 программа выводит только сообщение «ошибка».

Показать ответ
Ответ:
shybite
shybite
15.10.2020 07:18

var

a, b:String;

c, d:Integer;

begin

readln(a);

readln(c);

if (c < 3) or (c  > 150)

then begin

 writeln('Ошибка');

 exit;

 end;

readln(b);

readln(d);

if (d < 3) or (d  > 150)

then begin

 writeln('Ошибка');

 exit;

end;

if c > d then  

 writeln(a)

else  

writeln(b);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота