В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Lissa000
Lissa000
09.04.2022 03:49 •  Информатика

Pascalabc.net, обязательно через массивы, . напишите программу, ко­то­рая в по­сле­до­ва­тель­но­сти на­ту­раль­ных чисел опре­де­ля­ет мак­си­маль­ное число, крат­ное 4. про­грам­ма по­лу­ча­ет на вход ко­ли­че­ство чисел в последовательности, а затем сами числа. в по­сле­до­ва­тель­но­сти все­гда име­ет­ся число, крат­ное 4. ко­ли­че­ство чисел не пре­вы­ша­ет 1000. введённые числа не пре­вы­ша­ют 30 000. про­грам­ма долж­на вы­ве­сти одно число — максимальное число, крат­ное 4.

Показать ответ
Ответ:
artyom2980
artyom2980
07.09.2020 19:41

Компьютер, как и говорится в его названии (computer - вычислитель) служит для автоматизации процессов вычисления и обработки информации (которую можно, как оказалось, представлять количественно, в виде цифр).

Это позволяет автоматизировать большое количество рутинной работы, которая раньше выполнялась вручную.

Например, можно не тратить бумажки для хранения данных, а использовать базу данных, ускоряя доступ к данным посредством математических свойств данных.

Или не считать вручную выручку за квартал на предприятии, а использовать MS Excel для автоматических расчетов. Тот же Excel позволяет сразу вместе с расчетами полученные данные оформить в виде документа и отправить "на стол" начальству, а не идти из одного офиса в другой.

Помимо офисной работы автоматизируется также процесс производства. Начиная от черчения чертежей в Autocad (а не вручную, как раньше) и заканчивая полностью или наполовину автоматизированным производством деталей, посредством разработки встраиваемых систем или написания пакета программ для автоматизации.

Или сопровождение процесса работы. Например, расчет давления в подводящих трубах во избежание взрыва основной трубы. (Делается посредством решения огромной системы линейных уравнений с огромной разрежанной матрицей).

В целом, потенциал развития и применения компьютерных технологий огромен.

0,0(0 оценок)
Ответ:
makel200005
makel200005
23.07.2021 09:30

Можно код сделать покороче, если ты об этом.

program tri;

var

a, b, c: real;

begin

writeln('Введите a,b,c:');

readln(a, b, c);

if (a > 0) and (b > 0) and (c > 0) then

begin

if (a = c) and (b = c) and (a = b) then

writeln('Треугольник равносторонний') ;

if (((a = b) and (b <> c)) or

((b = c) and (b <> a)) or

((c = b) and (c <> a))) then

writeln('Треугольник равнобедренный');

if (a <> b) and (c <> b) and (a <> c) then

writeln('Треугольник произвольный') ;

end

else

writeln('такого треугольника нет') ;

end.

Ну вот, на 5 строчек короче, но смысл тот же.

Изменения:

Использовал if.. else вместо двух if при проверке положительности сторон. Собрал 3 if при проверке на равносторонность в один if.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота