В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Yarik200825
Yarik200825
18.12.2020 06:22 •  Информатика

Паскаль
1)Написать программу по нахождению суммы N четных чисел. ( S=2+4+6+…+2N).
2) Написать программу для нахождения введенных N чисел (P = P*a).

Показать ответ
Ответ:
Smekalenok
Smekalenok
02.04.2023 05:20

"...напечатает сначала 2, потом - 6" -- это значит a=2 и b=6?


про пятеричные записи ничего не понял...  :) И ИМХО к чему такие сложности? И для чего нам комп и программа? Я подправил исходную прогу чтобы она выдавала все числа подходящие по условию

var x,a,b: longint;


begin

   for var i := 999 DownTo 100 do begin

       a := 0;

       b := 1;

       x := i;

       while x>0 do begin

           if x mod 2 > 0 then a := a+1 else b := b+(x mod 5);

           x := x div 5;

       end;

       if (a = 2) and (b = 6) then writeln('x = ', i, ' a = ', a, ' b = ',b);

   end;

end.


прога проводит расчет для всх трехзначных чисел от 999 до 100

итого мы видим что максимальное подходящее число это 960

при необходимости прогу можно переделать чтобы она находила только максимальное число.

0,0(0 оценок)
Ответ:
azerzhanovaa
azerzhanovaa
02.02.2022 17:15

Если вы подходите к процессу съемки видео серьезно, то рано или поздно вы зададитесь вопросом о том, какой купить штатив для своей камеры. Штативы так же важны, как сама камера, но, к сожалению, часто при планировании бюджета штативам уделяется не так много внимания.

Штатив - это важный рабочий инструмент в видеосъемке. Качественные штативы не просто держат вашу камеру в фиксированном положении и позволяют избежать так называемой «шевелёнки». Также Они позволяют улучшить композицию кадра, держать нужный ракурс, обеспечивают плавное панорамирование и повороты камеры.

Объяснение:

тут я объяснил для чего нужен штатив камеры.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота