В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Виктор14253
Виктор14253
05.09.2021 08:14 •  Информатика

Паскаль.1)определите, сколько чисел, введённых пользователем делятся на 3 без остатка. ввод чисел пользователем заканчивается после ввода цифры 0. 2)найдите сумму цифр числа, меньших 5. например, для числа 715245 это будет 1+2+4=7. написать блок-схему и программу.

Показать ответ
Ответ:
ebanat3
ebanat3
11.06.2020 16:03

1)

program ABC;

var num,count:integer;

 

begin

readln(num);

while num<>0  do

begin

    if (num mod 3) = 3 then

          count:=count+1

end;

writeln(count)

end.

 

2)

program ABC;

var num,sum:integer;

 

begin

readln(num);

while num<>0  do

begin

    if (num mod 10) < 5 then

          sum:=sum+num mod 10;

    num:= num div 10

end;

writeln(sum)

end.

0,0(0 оценок)
Ответ:
Любимка97
Любимка97
11.06.2020 16:03

var
  C,count:integer;
begin
  write('Введите число ');
  count := 0;
  readln(C);
  while C <> 0 do
  begin
    if (C mod 3) = 0 then
      inc(count);
    write('Введите число ');
    readln(C);
  end;
  writeln('Count = ',count);
  readln;
end.

 

 

 

 

//вторая программа

 

var
  C, Summ:integer;
begin
  write('C = ');
  Summ := 0;
  readln(C);
  while C <> 0 do
  begin
    if (C mod 10) < 5 then
      inc(Summ, C mod 10);
    C := C div 10;
  end;
  writeln('Summ = ',Summ);
  readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота