В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
masha20321
masha20321
12.06.2022 19:32 •  Информатика

Паскаль 1.составить программу которая проверяет четное ли это число 2.составить программу которая уравнивает два числа a и b 3.составить программу которая проверяет трехзначное ли это число

Показать ответ
Ответ:
hhwjsbjweujskzks
hhwjsbjweujskzks
25.05.2020 10:25

1)

var

 num: integer;

begin

 writeln('Введите число');

 read(num);

 if(num mod 2 = 0) then  

   write('Число четное')

 else  

   write('Число нечетное');

end.

2)

var

 a, b, i: integer;

begin

 writeln('Введите a');

 read(a);

 writeln('Введите b');

 read(b);

 if (a > b) then

   swap(a, b);

 for i := 0 to  

 b - a - 1 do

   a := a + 1;

end.

3)

var

 num: integer;

begin

 writeln('Введите число');

 read(num);

 if (num div 1000 = 0) and (num div 100 <> 0) then  

   write('Число трехзначное')

 else  

   write('Число не трехзначное');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота