Паскаль! 1. Вводятся координаты трех точек. Какая из них находится ближе других к началу коордат? 2. Вводятся 4 натуральных числа. Определите максимальное произведение двух чисел. Например: для чисел 1,2,3,4 максимальное произведение двух мне вас
Const n=7; type V=array[1..n] of real; procedure mReplace(t:real;var a:V;var k:integer); var i:integer; begin k:=0; for i:=1 to n do if a[i]<t then begin a[i]:=t; Inc(k) end end;
var T:real; i,k1,k2:integer; P,C:V; begin Write('Введите значение T: '); Read(T); Writeln('Введите элементы массива P'); for i:=1 to n do Read(P[i]); Writeln('Введите элементы массива C'); for i:=1 to n do Read(C[i]); mReplace(T,P,k1); mReplace(T,C,k2); if k1>k2 then begin Writeln('Измененнный массив Р'); for i:=1 to n do Write(P[i],' ') end else if k2>k1 then begin Writeln('Измененнный массив C'); for i:=1 to n do Write(C[i],' ') end else Writeln('Число замен в массивах равно ',k1) end.
Тестовое решение: Введите значение T: 0.005 Введите элементы массива P 0.001 1.54 -2.75 0.002 -0.1 1.2 -0.47 Введите элементы массива C -5.74 0.0001 4.1 7.24 -1.5 2.9 0.004 Измененнный массив Р 0.005 1.54 0.005 0.005 0.005 1.2 0.005
#include <stdio.h>
#include <stdlib.h>
#include <time.h>
#include <cstdio>
using namespace std;
void main()
{
setlocale(LC_ALL, "Russian");
int i;
double s = 0, k, size;
double mas[200];
cout << "Введите размерность массива:";
cin >> size;
srand(time(NULL));
for (i = 0; i < size; i++)
{
mas[i] = 0 + rand() % 100; cout << mas[i] << " ";
}
cout << endl;
for (i = 0; i < size; i++)
{
s = s + mas[i];
}
k = s / size;
cout << "Среднее арифметическое:" << k <<endl;
system("pause");
}
n=7;
type
V=array[1..n] of real;
procedure mReplace(t:real;var a:V;var k:integer);
var
i:integer;
begin
k:=0;
for i:=1 to n do
if a[i]<t then begin a[i]:=t; Inc(k) end
end;
var
T:real;
i,k1,k2:integer;
P,C:V;
begin
Write('Введите значение T: '); Read(T);
Writeln('Введите элементы массива P');
for i:=1 to n do Read(P[i]);
Writeln('Введите элементы массива C');
for i:=1 to n do Read(C[i]);
mReplace(T,P,k1); mReplace(T,C,k2);
if k1>k2 then
begin
Writeln('Измененнный массив Р'); for i:=1 to n do Write(P[i],' ')
end
else
if k2>k1 then
begin
Writeln('Измененнный массив C'); for i:=1 to n do Write(C[i],' ')
end
else Writeln('Число замен в массивах равно ',k1)
end.
Тестовое решение:
Введите значение T: 0.005
Введите элементы массива P
0.001 1.54 -2.75 0.002 -0.1 1.2 -0.47
Введите элементы массива C
-5.74 0.0001 4.1 7.24 -1.5 2.9 0.004
Измененнный массив Р
0.005 1.54 0.005 0.005 0.005 1.2 0.005