Paskal abc 1. Напишите программу, имитирующую калькулятор. На вход подаются 2 целых числа и арифметический знак (+, -, *, /). Вывод написать в развернутом виде. Например: Входные данные Выходные данные
5 4 + 5+4=9 2. Напишите, которая по введенному числу из промежутка 0..24, определяет время суток. Например:
Входные данные Выходные данные
14 день
3. Напишите программу, которая по введенной букве (первые 5 букв алфавита) выводит Название города. Например:
//For
Var
ar:array[1..5] of integer;
i:integer;
r:real;
begin
for i:=1 to 5 do
begin
readln(ar[i]);
r:=r+ar[i];
end;
r:=r/i;
writeln(r);
end.
//while
Var
ar:array[1..5] of integer;
i:integer;
r:real;
begin
while i<>5 do
begin
i:=i+1;
readln(ar[i]);
r:=r+ar[i];
end;
r:=r/i;
writeln(r);
end.
//repeat
Var
ar:array[1..5] of integer;
i:integer;
r:real;
begin
repeat
i:=i+1;
readln(ar[i]);
r:=r+ar[i];
until i=5;
r:=r/i;
writeln(r);
end.
Пример ввода:
1
2
1
2
1
Пример вывода:
1.4
//For
Var
ar:array[1..5] of integer;
i:integer;
r:real;
begin
for i:=1 to 5 do
begin
readln(ar[i]);
r:=r+ar[i];
end;
r:=r/i;
writeln(r);
end.
//while
Var
ar:array[1..5] of integer;
i:integer;
r:real;
begin
while i<>5 do
begin
i:=i+1;
readln(ar[i]);
r:=r+ar[i];
end;
r:=r/i;
writeln(r);
end.
//repeat
Var
ar:array[1..5] of integer;
i:integer;
r:real;
begin
repeat
i:=i+1;
readln(ar[i]);
r:=r+ar[i];
until i=5;
r:=r/i;
writeln(r);
end.
Пример ввода:
1
2
1
2
1
Пример вывода:
1.4