В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
arseniy0114
arseniy0114
22.11.2021 23:06 •  Информатика

Паскаль abc вводится последовательность целых чисел n. найдите наибольший элемент последовательности не содержащий нулей. буду за

Показать ответ
Ответ:
vasx
vasx
09.10.2020 20:28
Var i,n,s,max: integer;
k,h: string;
begin
max:=0;
writeln('Введите кол-во чисел');
readln(n);
for i:=1 to n do
begin
readln(s);
Str(s,k);
if pos('0',k)=0 then
begin
if s>max then
max:=s;
end;
end;
writeln(max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота