В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ranki
ranki
11.10.2022 01:09 •  Информатика

ПАСКАЛЬ АБС 8 КЛАСС! Составьте программу, которая запрашивает время в часах (0, 3, 6, 9, 12, 15, 18, 21, 24) и рисует часы с показаниями часовой
стрелки (рис. 3.14).


ПАСКАЛЬ АБС 8 КЛАСС! Составьте программу, которая запрашивает время в часах (0, 3, 6, 9, 12, 15, 18,

Показать ответ
Ответ:
Умник6791
Умник6791
19.03.2021 00:01

PascalABC, проще уже некуда

Объяснение:

uses graphABC;

var  h: integer;

begin

 SetWindowSize(400, 400);

 Write('Введите время в часах(0, 3, 6, 9, 12, 15, 18, 21, 24): ');

 ReadLn(h);

 SetPenWidth(2);

 Circle(200, 200, 100);

 Line(200, 200, 200, 103);

 SetPenWidth(5);

 case h of

   0, 12, 24: Line(200, 200, 200, 105);  

   3, 15: Line(200, 200, 295, 200);  

   6, 18: Line(200, 200, 200, 295);  

   9, 21: Line(200, 200, 105, 200);  

 end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота