В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ВикаФан
ВикаФан
25.08.2021 03:33 •  Информатика

Паскаль авс.
вводится n целых чисел. написать программу подсчета количества чисел, в записи которых содержится цифра 8. при этом требуется написать функцию вида: function yes8(x: integer): boolean.

Показать ответ
Ответ:
26032004й
26032004й
04.05.2022 21:38

program z1; (Начало программы)

var n, s, i, c:integer; (Раздел описания переменных, n(кол-во чисел), s(сумма чисел), i(счетчик), с(число, введенное с клавиатуры))

begin (тело программы)

writeln ('Кол-во чисел?'); (подсказка для пользавателя)

readln (n); (считывание переменной)

s:=0; (обнуляем переменную)

For i:= 1 to n do begin (цикл будет повторяться от 1 до N; т.к в цикле будет несколько действий открываем операторные скобки (begin\end), начало цикла)

writeln ('Введите число'); (подсказка для пользавателя)

readln(c); (считывание переменной)

If c>0 then s:=s+c; (если с>0 тогда к сумме мы прибавляем число) 

end; (конец цикла)

writeln ('Сумма=',s); (подсказка для пользавателя и ответ)

readln(s); (считывание переменной)

readln; (считывание)

end.(конец программы)

0,0(0 оценок)
Ответ:
nastusya1709
nastusya1709
08.09.2021 03:27

Удивляюсь, как она  у меня заработала)) хаха

 

program example;
var x,y,z,a,b,c,i,k,l:integer;

begin
writeln ('Введите три числа');
write ('x = '); readln (x);
write ('y = '); readln (y);
write ('z = '); readln (z);

 

if ((x mod 3) or (x mod 2)) =0
then i:=x else i:=0;
if i<>0 then a:=1;

if ((y mod 3) or (y mod 2)) =0
then k:=y else k:=0;
if k<>0 then b:=1;

 

if ((z mod 3) or (z mod 2)) =0
then l:=z else l:=0;
if l<>0 then c:=1;

 

writeln ('Количество четных чисел, делящихся на три, равно ',a+b+c);
writeln ('Сумма четных чисел, делящихся на три, равна ',i+k+l);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота