В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ЭммаУаилд
ЭммаУаилд
25.04.2023 01:15 •  Информатика

Паскаль:через составной оператор Beginend составить программу, которая вычисляет сумму и среднее арифметическое положительных чисел

Показать ответ
Ответ:
ArinaKosareva63
ArinaKosareva63
14.10.2020 23:08

Program p1;

Var a, i, n, k,z: integer;

Begin

Write('Введите количество чисел: ');

readln(n);

k:=0;

z:=0;

For i:=1 to n do begin

readln (a);

if (a > 0) then k:=k + a;

z:=z + 1;

end;

Writeln('Сумма положительных чисел = ',k);

Writeln('Среднее арифметическое чисел = ',k/z);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота