В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
radmirsatabalov
radmirsatabalov
23.10.2022 11:16 •  Информатика

Паскаль. дан одномерный массив, состоящий из n вещественных чисел. напишите программу, которая должна осуществлять ввод и печать исходного массива; выполнять действия в соответствии с условием и печатать результаты.
вычислить произведение чисел, не равных заданному числу z, и подсчитать количество чисел, стоящих на нечётных местах и принадлежащих промежутку [a,b].

Показать ответ
Ответ:
uldairuslanova
uldairuslanova
12.05.2023 02:49

function fibonacchi(x:integer):integer;

// функция возвращает порядковый номер введённого числа

// ряда Фибоначчи. Если число не является элементом

// из данного ряда, то функция возвращает -1

var counter:integer = 2;

   s1,s2,s3:integer;

begin

   s1 := 0;

   s2 := 1;

   s3 := 0;

   if x = 0 then fibonacchi:=1

   else if x = 1 then fibonacchi:=2

   else begin

       while s3 < x do begin

           s3 := s1 + s2;

           s1 := s2;

           s2 := s3;

           inc(counter);

       end;

       if s3 = x then fibonacchi:=counter

       else fibonacchi:=-1;

   end;

end;

begin

   write(fibonacchi(13));

end.

0,0(0 оценок)
Ответ:
sotskova20041
sotskova20041
08.10.2022 20:38

Відповідь:

Профориентация

Школьникам

Взрослым

Студентам

Тесты

Список профессиий

FAQ

Статьи

Книги

Задать вопрос

ПрофГид

Профессии

Информационные технологии (IT)

Показаны записи 1-20 из 70.

Аналитик

Компьютерный лингвист

Инженер-программист

Архитектор интеллектуальных систем управления беспилотного транспорта

UI-дизайнер

UX-аналитик

UX-дизайнер

Художник компьютерной графики

Лингвоэксперт

Intelligent Systems Developer

Агроинформатик, агрокибернетик

Quant developer

Data Mining Specialist

BI разработчик (BI архитектор)

Программист Kotlin

Программист JavaScript

Программист C++

Биоинформатик

Архитектор информационных систем

Сценарист компьютерных игр

Пояснення:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота