В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
pdgjdis
pdgjdis
18.01.2023 11:46 •  Информатика

(паскаль) дан текстовый файл, содержащий вещественные числа (положительные и отрицательные) в произвольном порядке. сформируйте массив, содержащий только положительные числа из файла, и найдите наименьшее среди них.

Показать ответ
Ответ:
SHTUJDLXP
SHTUJDLXP
06.10.2020 12:18
Program filework;
var f:text;
    i, n, count:integer;
    l:string;
    arr:array of real;
    answ:real;
begin
  assign(f, 'C:\Users\HO4HOU_TTaPKuPucT\Desktop\test_file.txt'); // В кавычках путь к файлу
  reset(f);
  while not eof(f) do begin
    readln(f, l);
    if StrToFloat(l) > 0 then
    Inc(count);
  end;
  SetLength(arr, count);
  reset(f);
  i:=0;
  while not eof(f) do begin
    readln(f, l);
    if StrToFloat(l) > 0 then begin
      arr[i]:=StrToFloat(l);
      Inc(i);  
    end;
  end;
  answ:=arr[0];
  for i:=1 to arr.Length - 1 do
  if arr[i] < answ then answ:=arr[i];
  writeln(answ);
  close(f);
end.

P.S. Программа работает с неограниченным числом положительных чисел в файле
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота