В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
nastenadanil2698
nastenadanil2698
25.04.2023 12:13 •  Информатика

Паскаль дано четырёхзначное число. напишите программу которая выводит на экран самое большое число, которое можно составить из цифр заданного четырёхзначного числа

Показать ответ
Ответ:
pomogitejaslomalsya
pomogitejaslomalsya
03.10.2020 00:05
Var
a:array[1..4] of integer;
b,i,i2,max:integer;
Begin
Readln(b);
a[1]:= b div 1000;
a[2]:= b div 100 mod 10;
a[3]:= b div 10 mod 10;
a[4]:= b mod 10;
max:=1;
for i2:=1 to 4 do begin 
for i:=1 to 4 do if a[max]<a[i] then max:=i;Write(a[max]);
a[max]:=0;
End;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота