Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Тзх
19.12.2020 12:08 •
Информатика
Паскаль даны целое число k (1≤ k≤ 180) и последовательность цифр , в которой выписаны подряд все двухзначные числа. определить k-ю цифру.
Показать ответ
Ответ:
romamuver
01.10.2020 19:43
Var
k,i:integer;
s,x:string;
begin
for i:=10 to 99 do s:=s+IntToStr(i);
writeln(s);
write('Введите число k: ');
readln(k);
x:=s[k];
writeln(k,'-я цифра: ',x)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
вира7
02.09.2022 15:40
Сиспользованием цикла while do составить программу,которая рассчитывает выражение в=m(m++m) в случае целого числа m...
ziniakovarenatzinca
16.05.2022 03:25
Маша мечтает о покупке нового мощного компьютера, но родители поставили ей условие, что половину денег она должна заработать сама. Летом Маша устроилась работать на...
milaangel1
19.07.2020 11:40
Вэлектронной почте всегда автоматически создается папка - .. какая?...
Molyaneya
05.03.2023 01:20
Створити запит з новим обчислювальним полем «ВАРТIСТЬ» з полями «НОМЕР ЗАМОВЛЕННЯ», «НАЗВА ТОВАРУ», |«КРАЇНА ВИРОБНИК», «ФРМА ПОСТАЧАЛЬНИК», «ДАТА ПРОДАЖУ», «ЦНА», «КІЛЬКІСТЬ...
Queen2221
23.01.2023 04:58
сделайте здание впр 5 с 183. Книга: 6 класс Наталия морзе, Ольга Барна, Виктория Вембер...
ilariyao
17.05.2020 04:09
с заданиями, а то здесь вообще ничего не понятно. 1. Выберите правильный вариант ответа: Массив - это…A) упорядоченная последовательность данных, состоящая из конечного...
kikvadze123123
30.03.2020 16:23
Употребление глаголов (чтобы кратко и понятно) (7 класс)...
Pavel1810
06.05.2023 00:44
Выяснить от чего зависит сила магнитного действия знаю что надо перечислить каких то 3 вещи...
alinabilalova161
06.06.2020 18:01
Тіло , що перебувало в стані спокою , падає з висоти 20 м. на якій висоті швидкість руху тіла дорівнюватиме 10 м /с? опором повітря знехтуйте....
danchik1106
09.07.2020 06:21
Шығарып көр . серіктес 8түрлі қарындаш жəне 2жай қарындаш бар . ал нұрəліде 7түрлі түсті қарындаш жəне 1жай қарандаш бар. серік пиктограмма құрды. қайсысы тапсырманы...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
k,i:integer;
s,x:string;
begin
for i:=10 to 99 do s:=s+IntToStr(i);
writeln(s);
write('Введите число k: ');
readln(k);
x:=s[k];
writeln(k,'-я цифра: ',x)
end.