Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Goodok10
02.06.2023 18:46 •
Информатика
Паскаль. даны положительные числа a и b (a > b). на отрезке длины a размещено максимально возможное количество отрезков длины b (без наложений). не используя операции умножения и деления, найти длину незанятой части отрезка a.
Показать ответ
Ответ:
Krest007
25.08.2020 17:25
//Pascal ABC.NET 3.1 сборка 1219
Var
a,b:integer;
begin
read(a,b);
while a-b>=0 do
a:=a-b;
writeln(a);
end.
Пример ввода:
16
5
Пример вывода:
1
0,0
(0 оценок)
Популярные вопросы: Информатика
oksana341
24.11.2020 21:43
Учасникам забігу надали номери від а доb (а -b), цю інформацію занесли до комп ютера в зворотному порядку. Вивести номери спортсменів однією строчкою через проміжуток...
Мадина0911
08.04.2023 19:10
Який тег описує тіло документа?...
Сенси
17.12.2020 10:30
Определите значение переменной b после выполнения фрагмента алгоритма...
Tyxco
05.12.2020 01:05
Дан целочисленный массив из 20 элементов. элементы массива могут принимать целые значения от -10000 до 10000 включительно. опишите на языке программирования pascal алгоритм,...
Ziko88881
26.04.2022 05:14
1. какой логической операции соответствует таблица истинности (см. ниже)? * конъюнкция инверсия дизъюнкция импликация подпись отсутствует 2. какой логической операции...
mashasasha3
22.03.2020 07:29
Составьте программу изображения поля в полоску для этого нарисуйте разноцветные прямоугольники толщиной 20 пикселей расположенные друг под другом...
NikaAs1
15.08.2021 19:57
Определите значения переменных a и b после выполнения следующих операторов программы: program test; var a, b, i: integer; begin a: =3; b: =2; for i: =4 to 2 do a: =a+i;...
lady198026
06.05.2023 12:07
Паскаль. с клавиатуры введены 6 целых чисел. составьте программу, которая найдет из них наибольшее из них. использовать процедуру поиска большего из двух (бид)....
misha99672
31.12.2021 17:53
Надо! расширенный ответ дайте ...
STEPNOJORSK
27.11.2022 19:17
11)выберите правильный адресс ячейки: а)a12eb)4bc) 1$2$d)$d$19e)$10$l12)в таблице выделена группа ячеек a1: d4.сколько ячеек входит в этот диапазон? а)4в)16с)10d)5е)813)укажите...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
Var
a,b:integer;
begin
read(a,b);
while a-b>=0 do
a:=a-b;
writeln(a);
end.
Пример ввода:
16
5
Пример вывода:
1