В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Радькова32
Радькова32
26.05.2023 02:02 •  Информатика

Паскаль
даны значения двух моментов времени: часы, потом минуты и секунды. известно, что второй момент времени наступил не раньше первого и разница между ними менее суток. определите, сколько секунд между двумя моментами времени.

в первой строке входных данных находятся три целых числа — часы, минуты и секунды первого момента времени. во второй строке три числа, характеризующие второй момент времени. число часов лежит в диапазоне от 0 до 23, число минут и секунд — от 0
до 59. выведите число секунд между двумя моментами времени.

пример входных данных
1 1 1
2 2 2
1 2 30
1 3 20
пример выходных данных
3661
50

Показать ответ
Ответ:
bayramovameyra
bayramovameyra
11.10.2020 03:14

xD

uses crt;

var

dt,t1,t2:LongInt;

function GetTime:LongInt;

var

substr,str:string;

ERR,step,spacepos,code,num:Integer;

t:longint;

begin

ERR:=0;

repeat

t:=0;

step:=1;

if ERR<>0 then writeln('Nepravilnie dannie, povtorite vvod:');

ERR:=0;

readln(str);

str:=str+' ';

repeat

spacepos:=pos(' ',str);

if (spacepos<>0) then

begin

substr:=copy(str,1,spacepos-1);

delete(str,1,spacepos);

val(substr,num,code);

if code=0 then

begin

if (step=1) then begin if (num>=0) and (num<=23) then t:=t+num*60*60 else ERR:=3; end;

if (step=2) then begin if (num>=0) and (num<=59) then t:=t+num*60 else ERR:=3;end;

if (step=3) then begin if (num>=0) and (num<=59) then t:=t+num else ERR:=3;end;

inc(step);

end

else ERR:=2;

end else ERR:=1;

until ((step=4) or (err<>0));

until err=0;

GetTime:=t;

end;

begin

writeln('pervoe vremy:');

t1:=GetTime;

writeln('vtoroe vremy:');

t2:=GetTime;

if t2>=t1 then dt:=t2-t1 else dt:=t2-t1+24*60*60;

writeln('raznica v sekundah: ');

writeln(dt);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота