В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Leonelle
Leonelle
26.06.2020 12:56 •  Информатика

Паскаль. формирование массива длиной n элементов, зполняя его с клавиатуры, подсчет и вывод на экран количества символов из диапозона от а до я (кириллица вас -

Показать ответ
Ответ:
ismailtagiev20
ismailtagiev20
10.02.2021 13:57

Можно с большой степенью достоверности утверждать, что большинство приложений, которые предназначены для выполнения хотя бы какой-нибудь полезной работы, тем или иным образом используют структурированную информацию или, другими словами, упорядоченные данные. Такими данными могут быть, например, списки заказов на тот или иной товар, списки предъявленных и оплаченных счетов или список телефонных номеров ваших знакомых. Обычное расписание движения автобусов в вашем городе - это тоже пример упорядоченных данных.

При компьютерной обработке информации упорядоченные каким либо образом данные принято хранить в базах данных - особых файлах, использование которых вместе со специальными программными средствами позволяет пользователю как просматривать необходимую информацию, так и, по мере необходимости, манипулировать ею, например, добавлять, изменять, копировать, удалять, сортировать и т.д.

Таким образом, дать простое определение базы данных можно следующим образом. База данных - это набор информации, организованной тем, или иным , одним из самых банальных примеров баз данных может быть записная книжка с телефонами ваших знакомых. Наверное, у вас есть сейчас или когда-либо была эта полезная вещь. Этот список фамилий владельцев телефонов и их телефонных номеров, представленный в вашей записной книжке в алфавитном порядке, представляет собой, вообще говоря, проиндексированную базу данных. Использование индекса - в данном случае фамилии (или имени) позволяет вам достаточно быстро отыскать требуемый номер телефон

0,0(0 оценок)
Ответ:
12320071
12320071
24.06.2020 13:21

Начнем сначала. Паскаль является строго типизированным языком, значит чтобы использовать переменную, надо её сначала добавить в специальный блок var. 

Константы добавляются отдельно. 

Рассмотрим сперва неольшой пример, не имеющий отношение к твоей задаче:

program task1;

var i:integer;

begin

write("Vvedite i: ");

readln(i);

writeln(i);

end.

Программа просто попросит ввести i, запомнит введенное значение в ячейку с именем i.

Так вот чтобы разрешить использовать ячейку с именем i, мы и должны добавить её var i:integer; (ячейка i в которую можно класть целые числа, integer - целое по английски)

 

Теперь по твоему заданию:

1. в Паскале нет "переменных" чисел,

вот типы, которые есть в Паскале:

 

для целых чисел:
integer, диапазон -32768..32767
byte, диапазон 0..255
word, диапазон 0..65535
shortint, диапазон -128..127
longint, диапазон -2147483648..2147483647

 

для вещественных типов (в такие ячейки можно класть как целые числа, так и числа с точкой)

single (мало значащих цифр)

real (средне значащих цифр)
double (много значащих цифр)
extended (очень много значащих цифр)


логический тип
boolean может быть либо true либо false


Символьный тип
char просто любой символ, из поддерживаемых Паскалем (ASCII кодировка)

 

Таким образом фраза 

"Составить программу описания двух переменных чисел" понята мной как:

"Составить программу описания переменных:"

 

Итак, теперь программа:

program zadacha1;
var
d1,d2,d3:real; {dejstvitelnie, 3 stuki}
i1,i2,i3:integer;{celie, 3 shtuki}
const e=2.71; {Pervaya postojannaya}
g=9.8; {Vtoraya postoyannaya}
gravity=6.61; {Tretjya postoyannaya}
var c1,c2:integer; {dve celie, chislovie}
key:char; {odna simvolnaya}
begin
{zdes' teper' mozhno pisat' programmu}
end.

 

P.S. во вложении этот же исходный код, а на изображении еще и пример как класть значения в эти переменные.

 

Задавайте дополнительные вопросы

 


По информатике(паскаль) составить программу описания двух переменных чисел: трех действительн., трех
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота