В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
bonusalixova
bonusalixova
14.01.2023 20:23 •  Информатика

(паскаль или delphi) написать программу поиска двухзначных чисел, удовлетворяющих следующему условию: если к сумме цифр числа прибавить квадрат этой суммы, то получится само число.

Показать ответ
Ответ:
raxmatullin174
raxmatullin174
23.07.2020 16:22
Program z_3;
var a,b,n,s, i: integer;
Begin 
repeat  
writeln ('Введите Ваше число'); 
readln (n); 
if (n < 10) or (n > 99) then i:= 0 
else i:= 1; 
until i>0; 
a:= n mod 100 div 10; 
b:= n mod 10; 
s:= (a+b)+sqr (a+b); 
if s <> n then writeln ('Число не соотвествует условию') 
else writeln ('Число ',s, ' соответствует условию');
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота