В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
matany57
matany57
25.08.2021 12:22 •  Информатика

Паскаль. Используя оператор цикла с постусловием, составить программу вычисления суммы с заданной точностью:


Паскаль. Используя оператор цикла с постусловием, составить программу вычисления суммы с заданной то

Показать ответ
Ответ:
vladholyngha
vladholyngha
21.06.2021 18:40

Объяснение:

const eps = 0.0001; // Точность

var

  denom, step: integer;

  s, s1: real;

begin

    {Начальные значения}

    s := 1;

    s1:= 1;

    denom := 1;

    step := 3;

    // Вычисление суммы

    repeat

        s1 := s;  // Сохранить предыдущее значение

        denom := denom + step; // Увеличить знаменатель

        if (denom mod 2) = 0 then

           // Если четный знаменатель, вычитаем

           s := s - 1/denom

        else

            // Если нечетный знаменатель, складываем

            s := s + 1/denom;

    until (abs(s - s1) <= eps); // Проверка на точность

   // Вывод в консоль

    writeln('s =', s : 10: 8, '  s1 =', s1 : 10: 8, '  denom =', denom:10);

    readln();  // удержимаем консоль

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота