В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
LentaKuim
LentaKuim
22.03.2022 13:06 •  Информатика

Паскаль - массивы. написать программу, которая считает среднее число шагов в двоичном поиске для массива из 32 элементов в интервале [0,100]. для поиска использовать 1000 случайных чисел в этом же интервале.

Показать ответ
Ответ:
madisha12
madisha12
19.07.2020 22:17
Const
  n=32;
var
  a:array[1..n] of integer;
  i,j,k,p,left,right,center:integer;
begin
  { заполнить массив данными }
  Randomize;
  for i:=1 to n do a[i]:=Random(101);
  { отсортировать массив во возрастанию - пузырьковый метод }
  for i := 1 to n-1 do
    for j := 1 to n-i do
      if a[j] > a[j+1] then
      begin k := a[j]; a[j] := a[j+1]; a[j+1] := k end;
  { тысяча поисков случайных чисел }
  k:=0;
  for j:=1 to 1000 do
  begin
    p:=Random(101);
    { собственно, двоичный поиск }
    left:=1; right:=n;
    while left<right do
    begin
      Inc(k);
      if (a[left]=p) or (a[right]=p) then left:=right { нашли }
      else begin
        center:=(left+right) div 2;
        if a[center]=p then left:=right { нашли }
        else
          if a[center]<p then left:=center+1
          else right:=center
      end
    end
  end;
  Writeln('Среднее число поисков равно ',k/1000:4:2)
end.

Тестовое решение:
Среднее число поисков равно 4.61
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота