В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
marisa10
marisa10
08.02.2020 07:23 •  Информатика

Паскаль. много . дано целое трехначное число x.составьте программу вычисления суммы и произведения цифр трехзначного числа x. знасение x ввести с клавиатуры. тема с div и mod.

Показать ответ
Ответ:
MoLoDaYa666
MoLoDaYa666
07.10.2020 22:15
//Pascal
//Для натуральных чисел
var a, s, p:integer;

begin
  write('Введите число = ');
  readln(a);
  s := 0;
  p := 1;
  while (a<>0) do
  begin
    p := p * (a mod 10);
    s := s + (a mod 10);
    a := a div 10;
  end;
 writeln( 'Сумма цифр числа = ', s);
 writeln( 'Произведение цифр числа = ', p);
end.

//Если число отрицательное
var
  s, p, a, b, c: integer;
  f: boolean;
begin
  write('Введите число = ');
  readln(a);
  if a < 0 then
    f := true;
  a := abs(a);
  b := a mod 10;
  a := a div 10;
  c := a mod 10;
  a := a div 10;
  if f = true then
  begin
    p := (-a) * b * c;
    s := -a + b + c;
  end
  else
  begin
    s := a + b + c;
    p := a * b * c;
  end;
  writeln('Сумма цифр числа = ', s);
  writeln('Произведение цифр числа = ', p);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота