В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
arave1
arave1
06.08.2022 14:26 •  Информатика

Паскаль написать программу,которая будет открывать txt файл,искать нужный текст и удалять его.после чего сохранит изменения. нужно использовать цикл,т.к.поиск будет осуществляться много раз! txt файл большой,с большим количеством перехода на новую строку.

Показать ответ
Ответ:
Uniquehatter
Uniquehatter
08.07.2020 13:03
Лучше писать результат не в тот же файл, а в другой: при составлении регулярных выражений без достаточного опыта можно легко ошибиться.

uses
  System.Text.RegularExpressions;

const
  CRLF = #13#10;

var
  s, sbig: string;
  fin, fout: Text;

begin
  Assign(fin, 'MyIn.txt');
  Reset(fin);
  sbig := '';
  while not Eof(fin) do
  begin
    Readln(fin, s);
    sbig := sbig + s + CRLF
  end;
  Close(fin);
  {пример - уладить подстроки, начиная с "http:" и до первого пробела,
  причем внутри подстроки может встретиться переход на новую строчку.
  Используется шаблон '\bhttp:\S+' - подробности: регулярные выражения}
  sbig:=RegEx.Replace(sbig, '\bhttp:\S+', '', RegexOptions.Multiline);
  Assign(fout, 'MyOut.txt');
  Rewrite(fout);
  Write(fout, sbig);
  Close(fout);
  Writeln('Конец работы');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота