В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
edshabashenko
edshabashenko
09.04.2022 11:37 •  Информатика

Паскаль.Написать программу по которой из введённого массива А в массив В копируются только положительные элементы массива А

Показать ответ
Ответ:
MiklJackson
MiklJackson
02.02.2020 23:04
У меня код на Си. Сумеешь перенести на плюсы?

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <locale.h>

int main() {
setlocale (LC_ALL, "RUS");
int a, b, S, P;

printf("Введите длину прямоугольника: ");
scanf ("%d", &a);
printf("Введите ширину прямоугольника: ");
scanf ("%d", &b);

S = a * b; P = (a + b) * 2;
printf ("Площадь - %d \n Периметр - %d \n", S, P);
if (S > P)
printf ("Площадь больше периметра\n");
else
printf("Периметр больше площади\n");

system ("pause");
return 0;
}
0,0(0 оценок)
Ответ:
Lana0602
Lana0602
13.07.2021 06:39
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace ConsoleApplication4
{
    class Program
    {
        static void Main(string[] args)
        {
            int n = 20;
            int[] mass = new int[n];
            mass[0] = 1;
            mass[1] = -1;

            for (int i = 2; i < n; i++)
            {
                mass[i] = mass[i - 2] + mass[i - 1];
            }

            int sum = 0;
            for (int i = 6; i < 20; i++)
            {
                sum += mass[i];
            }

            Console.WriteLine("Сумма равна " + sum);
            Console.ReadKey();
        }
    }
}

на выводе получаем -4176
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота