В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
dinaumralieva
dinaumralieva
26.06.2021 10:38 •  Информатика

ПАСКАЛЬ
Написать программу
Задачи на строки
Даны две произвольные строчки. Совпадают ли они побуквенно?

Показать ответ
Ответ:
diasashat11
diasashat11
11.10.2020 11:24

program sovpadenie_strok;

uses crt;

var

s1,s2:string;

i:integer;

f:boolean;

begin

read(s1);

read(s2);

if (length(s1)=length(s2))then

begin

i:=1;

f:=false;

while(i<length(s1))and(f=false)

do

begin

if s1[i]<>s2[i] then f:=true;

i:=i+1

end;

if f=true then

write('Строки побуквенно не совпадают')

else

write('Строки побуквенно совпадают')

end

else

write('Строки разной длины')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота