В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
natslig
natslig
09.12.2022 14:55 •  Информатика

Паскаль напишите программу для решения следующей . участники парусной регаты стартовали одновременно.на финише фиксировалось время прохождения маршрута каждой яхтой(в часах и минутах).определите время победителя регаты(в часах и минутах).известно, что соревнования проходили в течение 12 часов.
программа получает на вход количество яхт, принимавших участие в регате n (1< или равно n < или равно 100), затем для каждой яхты вводится 2 числа: часы и минуты, затраченные на прохождение маршрута. пример: входные данные 2, 3, 25, 2, 50.выходные данные 2, 50. напишите каждое действие,
как стоит написать в программе, с каждой запятой и тп

Показать ответ
Ответ:
maksfire
maksfire
03.03.2021 10:19
Var
  s: string;
  i, j, n: integer;
  c: char;
  flag: boolean;

begin
  Write('Введите произвольное число: '); Readln(s);
  flag := false;
  n := length(s);
  i := 1;
  while (i <= n) and (not flag) do
  begin
    c := s[i];
    j := i + 1;
    while (j <= n) and (not flag) do
      if s[j] = c then flag := true else j := j + 1;
    if (not flag) then i := i + 1
  end;
  if flag then Writeln('Символ "', c, '" встречается больше одного раза')
  else Writeln('Все символы уникальны')
end.

Тестовое решение:
Введите произвольное число: 16379068
Символ "6" встречается больше одного раза
0,0(0 оценок)
Ответ:
дядя22323
дядя22323
30.07.2022 14:22
1.Некоторая часть окружающего мира, воспринимаемая человеком как единое целое, называется …
а) предметом  б) объектомв) модельюг) системой
2. Основной характеристикой объекта является:а) средаб) имяв) параметрг) действие3. Укажите отношение для пары «процессор и системный блок»:
а) является элементом множестваб) входит в составв) является разновидностьюг) является причиной4. Информационной моделью части земной поверхности является:а) глобус Землиб) план домав) карта местностиг) схема метро5.Какая модель реализуется средствами программной среды?а) информационная вербальная модельб) информационная некомпьютерная модельв) информационная компьютерная модельг) материальная компьютерная модель6. В информационной модели автомобиля в описании  «По дороге,  как ветер, промчался лимузин»  отражается его:а) размерб) цветв) скоростьг) форма7. Составить в табличной форме информационную модель элементов системы «классная комната».II вариант1. Целое, состоящее из объектов взаимосвязанных между собой?а) модельб) структурав) системаг) совокупность2. К признакам объекта не относится:а) цветб) размерв) формаг) материал3. Укажите отношение для пары "графический редактор и MS Paint":
а) является элементом множестваб) входит в составв) является разновидностьюг) является причиной4. При создании игрушечного корабля для ребёнка трёх лет существенным является:а) внешний видб) размерв) точностьг) цветд) материал5. Выберите, что можно моделировать.а) объектыб) явленияв) процессыг) поведениед) все выше перечисленное6. В информационной модели компьютера, представленной в виде схемы, отражается его:а) весб) цветв) формаг) структурад) размер7. Составить в табличной форме информационную модель элементов системы «садовый участок».III вариант1. Аналог оригинала, отражающий некоторые его характеристики,  называется…а) предметом б) объектомв) модельюг) системой
2. К величинам объекта не относится:а) весб) размерв) формаг) возраст3. Укажите отношение для пары «василёк и полевые цветы»:
а) является элементом множества;б) входит в состав;в) является разновидностью;г) является причиной.4. В информационной модели жилого дома, представленной в виде чертежа, отражается его:а) структураб) цветв) стоимостьг) надёжностьд) удобство5. Какую модель нельзя потрогать или увидеть воочию, т.к. она не имеет материальной основы, а строится только на информации?а) материальнаяб) информационнаяв) физическаяг) логическая6. Модель человека в виде детской куклы создана с целью:а) изученияб) познанияв) игрыг) рекламыд) продажи7. Составить в табличной форме информационную а) средаб) действиев) состояниег) процесс3. Укажите отношение для пары "взрыв и пожар":
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота